NetCeiver Hardware Diagnose

Aus RMM-Wiki
Wechseln zu: Navigation, Suche

Um bei evtl. Stromversorgungs oder Firmware-Problemen besser helfen zu können, sind hier mal konzentriert der Bootvorgang und die diversen LED-Blinkereien samt Diagnosemöglichkeiten des NetCeivers beschrieben.

Grundlage: Es gibt einen kleinen Prozessor, der sich um die SD-Karte kümmert und mit den Files dann den grossen (FPGA) lädt und ihn auch noch mit einem Linux versorgt. Dabei greifen 2 "BIOSe" vom kleinen und grossen Prozessor ineinander, die ihren Gemütszustand über 3 LEDs ausgeben, eine beim SD-Slot, zwei zwischen Tunerslot 2 und 3. Die Tuner-LED zur Rückseite hin nennen wir mal LED1, die andere LED2.


0) Power off, alle LEDs aus

1) Power on.

Beim externen NetCeiver sollte sofort die rote LED auf der Stomversorgungsplatine aufleuchten. Die hängt allerdings "nur" an den erzeugten 12V. Sollten aus irgendwelchen Gründen die 3.3V oder die 5V nicht passen, bleibt das zunächst unbemerkt.

Bei den S2-Doppeltunern ist ein leichtes Klackern normal, kommt vom LNB-Loop-Through-Relais.

2) NetCeiver sucht SD-Karte: SD-LED leuchtet ca. 1s auf, geht 0.1s aus und leuchtet 0.5s auf.

Ohne korrekt eingesteckte/erkannte SD-Karte ist danach ca. 0.4s Pause und es geht wieder von vorne los.

3) Netzwerkkarte erkennt Link, die mittlere LED (100Mbit) geht an, auch bei GBit.

Ohne eingestecktes Kabel tickt die Netzwerkkarte übrigens leise so alle 0.3s.

2+3) heisst übrigens auch, dass die 5V sauber anliegen.

4) NetCeiver findet und lädt fpga.bin auf der SD-Karte: SD-LED geht von 2) nahtlos in ca. 2s langes leichtes Flackern über, danach erstmal aus.

5) Grosser Prozessor im FPGA startet. LED1 und LED2 gehen an, wird durch 6) aber schon schnell wieder überschrieben, dass man das gar nicht sieht, ausser Major F*ckup.

6) FPGA-Bios macht Speichertest der 64MB DDR-RAM: Kurzes schnelles Flacken (0.5s lang) von LED1 und LED2. Falls was schiefgeht, blinken LED1 und LED2 ABWECHSELND sehr schnell (.1s LED1, .1s LED2). Ausser dem Blinken passiert danach nichts mehr.

7) BIOS initialisiert PCI: LED1+2 aus, aber nur sehr kurz.

8) BIOS sucht und lädt image.bin von der SD-Karte: SD-LED flackert unregelmässig, LED1+2 flackern regelmässig (1 doppelt so schnell wie 2), Dauer ca. 7-9s.

Ist kein image.bin vorhanden, blinken LED1 und 2 ABWECHSELND, aber langsam (1s LED1, 1s LED2).

9) BIOS startet Linux: LED1+2 bleiben auf dem letzten Stand stehen. Erstmal Ruhe für ca. 8s, der Pinguin muss sich häuslich einrichten.

10) Linux erkennt Netzwerkkarte: Linkstatus geht auf Gbit (obere grüne LED)

11) Linux erkennt und mountet SD-Karte: Die SD-LED flackert innerhalb von 1-2s ein paar mal.

12) Linux startet Streaminganwendung "mserv": Tuner werden initialisiert, ist unsichtbar, dauert je nach Typ und Anzahl der Tuner 2-10s.

13) mserv lädt netceiver.conf von der SD-Karte: SD-LED flackert kurz.

Tritt das nicht auf, könnte es sein, dass /etc/rc.d/S25mserv auf der SD-Karte fehlt und damit mserv nicht gestartet wird.

14) mserv aktualisiert netceiver.conf auf die SD-Karte: Je nach Anzahl der Tuner und Länge der Sat-Listen flackert die SD-LED nach weiteren 2-10s für 1-2s.

15) Normaler Betriebsmodus: regelmässig LED2 2s an, 2s aus, LED1 flackert unregelmässig bei eingehenden Verbindungsanfragen.